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Defining & running Circuit 
Simulation analyses 

Summary  
Tutorial  
TU0106 (v1.4) January 23, 2006   

This tutorial looks at creating a schematic of an analog filter 
design that is set up for circuit simulation. It covers setting 
up and running some analyses on a schematic and viewing 
the results in the Waveform Analyzer. 

 

 

This tutorial starts by creating a simulation-ready schematic on which we will run our circuit simulation 
analyses. We will create a new project file first and then add a new blank schematic sheet. 

Creating a new project 
To start the tutorial, create a new PCB project: 
1. Select File » New » Project » PCB Project from the menus, or click on Blank Project (PCB) in the 

New section of the Files panel. If this panel is not displayed, click on the Files tab at the bottom of 
the workspace panels. 
Alternatively, you could select Printed Circuit Board 
Design in the Pick a Task section of the Altium Designer 
Home Page (View » Home) and then click on New Blank 
PCB Project. 

2. The Projects panel displays. The new project file, PCB 
Project1.PrjPCB, is listed here with no documents 
added.  

3. Rename the new project file (with a .PrjPCB extension) by selecting File » Save Project As. 
Navigate to a location where you would like to store the project on your hard disk, type the name 
Filter.PrjPCB in the File Name field and click on Save. 

Next, we will create a schematic to add to the empty project file. This schematic will be for a Filter 
circuit. If you do not have the time to draw the schematic from scratch, open a similar project 
Filter.PrjPCB found in the \Program Files\Altium Designer 6\Examples\Circuit 
Simulation\Filter folder. 

Creating a new schematic sheet 
Create a new schematic sheet by completing the following steps:  
1. Select File » New » Schematic. A blank schematic sheet named Sheet1.SchDoc displays in the 

design window of the Schematic Editor and the schematic sheet is now listed under Source 
Documents beneath the project name in the Projects panel. 
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2. Rename the new schematic file (with a .SchDoc extension) by selecting File » Save As. Navigate 
to a location where you would like to store the schematic on your hard disk, type the name 
Filter.SchDoc in the File Name field and click on Save. 

Drawing the schematic 
Now we can create the Filter circuit shown below in Figure 1. Before we can run a simulation, the 
schematic must contain components with SIM models attached, voltage sources to power the filter, an 
excitation source, a ground reference for the simulations and some net labels on the points of the 
circuit where we wish to view waveforms. 

In this section of the tutorial, we will locate the components required, set up their component properties 
and then wire the schematic. 

 

Figure 1. Filter.SchDoc 

Locating components and loading libraries 
First, we will search for the op amp component, LF411CN. 

1. Click on the Libraries tab to display the Libraries workspace panel. 

2. Press the Search button in the Libraries panel, or select Tools » Find Component. This will open 
the Libraries Search dialog. 

3. Set the scope to Libraries on Path and make sure that the Path field contains the correct path to 
your libraries. If you accepted the default directories during installation, the path should be 
C:\Program Files\Altium Designer 6\Library\. Click on the folder icon to browse to the 
library folder, if necessary. Ensure that the Include Subdirectories box is selected (ticked). 
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4. We want to search for all references to LF411, so in the search text field at the top of the Libraries 
Search dialog, type *LF411*. The * symbol is a wildcard used to take into account the different 
prefixes and suffixes used by different manufacturers. 

 

5. Click on Search and the query results display in the Libraries panel as the search takes place. The 
component we need is found in the NSC Operational Amplifier.IntLib library. 

Placing a simulation-ready component 
The first component we will place on the schematic is the op amp, U1. For the general layout of the 
circuit, refer to the schematic drawing shown in Figure 1.  
1. Click on LF411CN in the Components list of the Libraries panel to select it and click on Place 

LF411CN. Alternatively, just double-click on the component name.  

2. The Confirm dialog will display if the library has not been installed.  

 

3. Click on Yes to install the library. An outlined version of the op amp appears “floating” on the 
cursor. You are now in part placement mode.  

4. Before placing the part on the schematic, first edit its properties. While the op amp is floating on the 
cursor, press the TAB key to open the Component Properties dialog for this component.  
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5. In the Properties section of the dialog, set the value for the first component designator by typing U1 
in the Designator field. 

6. Next, we will have a look at the SIM model that will be used when running the simulation. For this 
tutorial, we have used 
integrated libraries, which 
mean that the recommended 
models for circuit simulation 
are already included. Select 
LF411_NSC in the Models list 
in the Component Properties 
dialog and click on Edit to 
display the SIM Model – 
General / Generic Editor 
dialog. 

7. Notice that the model file 
path name has been set and 
successfully found in the NSC 
Operational 
Amplifier.IntLib 
integrated library.  
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Altium Designer 
simulator supports 
Spice 3F5 models, 
and most PSpice 
models. 

Click on the Model File tab to display the contents of the model file. If no model file has been 
found, an error message will appear in this tab. 

 

8. The Netlist Template (shown by clicking on the Netlist Template tab) will now be filled with data 
from the model file and can be viewed by clicking on the Netlist Preview tab. 

    

Click OK until all dialogs are closed.  

You are now ready to place the op amp on the schematic sheet. 

9. If you refer to the schematic diagram (Figure 1), you will notice that U1 is placed as a mirror of the 
symbol that is floating on the cursor. To flip the orientation of the op amp vertically before final 
placement, press the Y key. Position the component on the sheet and left-click or press ENTER to 
place it onto the schematic sheet. 

10. Exit part placement mode by right-clicking or pressing the ESC key.  

Adding a new SIM model file 
SPICE models used for circuit simulation (.ckt and .mdl files) are located within the integrated 
libraries in the C:\Program Files\Altium Designer 6\Library folder. You must use the 
correct file extension for each model type. For example, a SPICE .subckt will not be found unless it is 
in a *.ckt file, nor will a SPICE .model if it is not in a *.mdl file.  

The Model Name is the crucial link to the SIM model file, so make sure it is a valid model name. To find 
existing model file names in the Altium integrated libraries: 
1. Click on the Search button in the Libraries panel. The Libraries Search dialog appears. 

2. To search for all Simulation models available in the supplied libraries, type in the following query:  
HasModel('SIM','*',False) and click on the Search button. 

You can also narrow down the search by adding more detail to the query, e.g. to find any LF411 
related circuit files, use the following query: 
HasModel('SIM','*LF411*',False) 

For more information about queries, use the Query Helper (click on the Helper button in the 
Libraries Search dialog) or refer to the Query Language Reference in the Inside the Altium 
Designer Environment book (online only). 

3. Search results will display in the Libraries panel. 
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You may want to use a simulation model in your design other than the one already supplied with the 
component in its integrated library. It is recommended that you copy any model files received from a 
manufacturer into your design’s project file.  

If you want to use a simulation model that resides in another integrated library: 
1. Open the .Intlib file that contains the required model (File » Open and confirm you want to 

extract the source libraries).  

2. Copy the model files from the output folder (generated when you opened the integrated library) into 
the folder that contains your project. You can then add this model and make modifications, if 
required, using the Sim Editor. 

For the sake of demonstration, we will add in another SPICE model, LF411C.ckt, located in the 
\Program Files\Altium Designer 6\Examples\Circuit Simulation\Filter folder.  

1. Copy LF411C.ckt and paste this file into the folder where your project files reside using Windows 
Explorer. 

2. Add the model file to the project by selecting the project name (Filter.PrjPCB) in the Projects 
panel, right-click and select Add Existing to Project. Choose the model file and click Open. The 
SPICE model file LF411C.ckt is added to the project under the Libraries\AdvancedSim 
Sub-Circuits folder in the Projects panel. 

Now we can add the model to the component in the schematic. This could also be done in the 
Schematic library for this component, if required. 

3. Double-click on the op amp (U1) to open its Component Properties dialog. Delete the existing SIM 
model in the Models section by selecting it and clicking on Remove and confirming the deletion. 

4. Click on Add in the Models List section to display the Add New Model dialog.  

5. Select Simulation from the Model Type drop-down list and click OK. The SIM Model – General / 
Generic Editor dialog displays.  

6. Select Spice Subcircuit from the Model Sub-Kind list to set the Spice Prefix to X and display the 
Model Location fields. The dialog name changes to reflect the Model Sub-Kind.  
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7. Type LF411C in the Model Name field (no extension required) and select the Model Location of 
Any to search all valid libraries for a matching model.  

Altium Designer stops searching for a model as soon as a match is found. For all models not tied to 
an integrated library, the search will proceed to model files added to the project and then to model 
files found on the Search Paths as set up in the Search Paths tab of the Options for Project dialog 
(Project » Project Options). In this example, the search will find the model file LF411C.ckt 
located in the project folder. 
Whenever a model search does not find a match, an error will appear in the Model File tab. An 
interactive error will also appear in the Messages panel when you compile the project.  

8. The final step is to check the pin mapping of the new model to make sure that it matches the pin 
numbering of the schematic component. Click on the Port Map tab of the SIM Model – General / 
Spice Subcircuit dialog.  

 

9. Modify the pin mapping to be the same as that used for the original SIM model (LF411_NSC) by 
selecting the matching pins from the Model Pin drop-down lists (see the dialog above for details).  
The way to work out the order of the pin numbers is to look at the Netlist Template tab. Note that 
the order for this model is 1, 2, 3, 4, 5. 

 

These correspond to the .SUBCKT header found in the Model File tab, even though these numbers 
may not match identically in other models as they do in this particular model file. 
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Therefore, in the Model Pin column of the Port Map tab, you will see listed 1(1), 2(2), 3(3), 4(4), 
5(5), where the first number is the model 
pin number (%1, %2, etc. from the Netlist 
Template) and the corresponding node 
name/number from the subcircuit header is 
enclosed in brackets. 

The actual numbers in the subcircuit 
header are not important; what is important 
is the order in which the connections 
appear in the Spice netlist. These must 
match the order in the header of the 

.SUBCKT, e.g. Non-Inverting Input (IN+), Inverting Input (IN-), Positive Power Supply (V+), 
Negative Power Supply (V-) and Output (OUT). 

The netlist header describes the function of each pin. Use this information to link them to 
the appropriate schematic pin. For example: 

1(1) is the + input (non-inverting input), so links to schematic pin 3(IN+), and 

5(5) is the output so links to schematic pin 6(OUT). 
10. When you have modified the pin mapping, click OK until all dialogs are closed. 

Now we will continue with setting up our Filter schematic for simulation. 

Setting up simulation-ready resistors 
Next, we will place the two resistors. 
1. In the Libraries panel, make sure the Miscellaneous Devices.IntLib library is active. 

2. Set the filter by typing res1 in the filter field below the Library name. 

3. Click on Res1 in the components list to select it and then click the Place button. You will now have 
a resistor symbol floating on the cursor. 

4. Press the TAB key to edit the resistor’s properties. In the Properties section of the dialog, set the 
value for the first component designator by typing R1 in the Designator field. 

5. Set up a parameter field for the resistor that will display on the schematic and be used by Altium 
Designer when running the circuit simulation later in this tutorial. The Value parameter can be used 
for any general component information but discrete components use it when simulating.  

Original pin mapping Modified pin mapping 
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If there is not a Value parameter already included in the component properties, click Add in the 
Parameters list section to display the Parameter Properties dialog. Enter the name Value and a 
value of 100k. Make sure String is selected as the parameter type and the value’s Visible box is 
ticked. Click OK. 

6. In the Properties section of the dialog, click on the Comment field and select the =Value string 
from the drop down list and turn Visible off. Rather than enter the value twice (in the parameter 
Value and then in the Comments field), Altium Designer supports ‘indirection’ which will replace the 
contents of the Comments field with the parameter’s string. This data can then be transferred to the 
PCB or BOM for example without the need to enter it twice. 

7. Let’s check the SIM model RESISTOR in the Models list. Select the model name in the Models list 
and click on Edit to display the Sim Model – General/Resistor dialog. This type of resistor does not 
require a model file and takes the value required by the Netlist Template from the Value parameter. 

 

Click OK to close the dialog and return to the Component Properties dialog. Click OK. 

8. Position the resistor (refer to the schematic diagram in Figure 1) and left-click or press ENTER to 
place the part. 

9. Now place resistor R2. The designator will automatically increment when you click to place it. 
10. Once you have placed the resistors, right-click or press ESC to exit part placement mode.  

Setting up simulation-ready capacitors 
Now find and place the two capacitors. 
1. The capacitor part is also in the Miscellaneous Devices.IntLib library, which should 

already be selected in the Libraries panel. Type cap in the component’s filter field in the Libraries 
panel. Click on CAP in the components list to select it and click the Place button.  
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2. Press the TAB key to edit the capacitor’s properties. In the Properties section of the Component 
Properties dialog, set the Designator to C1. 

3. Change the Value field of the Value parameter to 112pF. Make sure String is selected as the 
parameter type and the value’s Visible box is ticked. 

4. In the Properties section of the dialog, click on the Comment field and select the =Value string 
from the drop down list and turn Visible off.  

5. Let’s check the SIM model CAP that has been added to the Models list from the integrated library. 
Select the model name in the Models list and click on Edit to display the Sim Model – 
General/Capacitor dialog. This capacitor does not require a model file and takes the required value 
from the Value parameter.  

 

6. Click OK to return to the Component Properties dialog. Click OK to return to placement mode. 

7. Position and place the two capacitors in the same way that you placed the previous parts, changing 
the value to 56pF for C2 and pressing the SPACEBAR to rotate the symbol. 

8. Right-click or press ESC to exit placement mode. 

Adding the voltage sources 
Now we can add the voltage sources needed to power the design when simulating. 
1. We will place the VDD power source first. Search for the component VSRC in the Libraries panel 

and then add the Simulation Sources.IntLib library to the Available Libraries list. Note that 
there are other simulation libraries available in the \Project Files\Altium Designer 
6\Library\ Simulation folder. 

As you place the power source, press TAB to edit its properties.  
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2. Click on the SIM model VSRC in the Models list in the Component Properties dialog and click on 
Edit. In the Sim Model – Voltage Source/DC Source dialog, check the Model Kind is set to Voltage 
Source and the Model Sub-Kind to DC Source. 

 

3. Click on the Parameters tab to set up the voltage value required. Type 5V in the Value field and 
tick its Component Parameter box. This will automatically create the parameter ‘Value’ for you in 
the Component Properties dialog. Leave the other fields set to zero.  

 

Click OK until the dialogs are closed. Click to place this voltage source on the schematic. Right-
click or press ESC to exit placement mode. 

4. Now place the VSS power source, remembering to set the model file parameter Value to -5V. 
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To place the power 
ports from a 
specialized toolbar, 
select View  » 
Toolbars » Utilities 
and click on the 
required power port 
button. 

5. Finally add the Sinusoidal (excitation) 
Voltage Source, VSIN, also available from 
the Simulation Sources.IntLib. 
Press TAB to edit its properties before 
placing and change the frequency from 
1KHz to 50KHz for this example. In the 
Component Properties dialog, click on the 
SIM model VSIN in the Models list and 
click on Edit.  
In the Sim Model – Voltage Source / 
Sinusoidal dialog, check the Model Kind is 
Voltage Source and the Model Sub-Kind 
is set to Sinusoidal. 

6. Click on the Parameters tab to set up the 
voltage value required. Type in the 
parameter values as shown in the Sim 
Model – Voltage Source / Sinusoidal dialog 
(see right). The Netlist Template is 
evaluated using this information and displayed in the Netlist Preview. 
Click OK until the dialogs are closed and click to place this voltage source on the schematic. Right-
click or press ESC to exit placement mode. 

7. Save your schematic [shortcut Ctrl+S]. 

Adding power ports 
Add the power ports on the Filter schematic as shown in Figure 1. 
1. Select Place » Power Port. Press TAB to set the power port settings in the 

Power Port dialog.   

2. For the ports attached to the components’ pins, type in the corresponding net 
name, e.g. VSS, and set the style to Bar. Click OK and place the power port by 
left-clicking or pressing ENTER. Use the SPACEBAR to rotate the port during 
placement. 

3. Continue placing the power ports. Set the style to Power Ground and the net 
to GND when adding the power ports to the power sources (VIN, VDD and VSS). The OUT port is 
net OUT and has a Circle style. 

4. When finished placing the power ports, right-click or press ESC to exit placement mode.  

Wiring up the circuit 
Wiring is the process of creating connectivity between the various components of your circuit. To wire 
up your schematic, please refer to the diagram in Figure 1. 
1. Select Place » Wire [shortcut P, W] or click on the Wire tool from the Wiring Tools toolbar to enter 

wire placement mode.  



Defining & running Circuit Simulation analyses 

TU0106 (v1.4) January 23, 2005 13 

For more information about wiring a schematic, refer to the tutorial Getting Started with PCB 
Design in the Getting Started with Altium Designer book. 

2. Right-click or press ESC to exit wire placement mode.  

Nets and net labels 
Our last task before running a simulation is to place net labels at appropriate points on the circuit so we 
can easily identify the signals we wish to view. In the tutorial circuit, the points of interest are the IN and 
OUT nets. The IN net is identified with a net label while the OUT net name is read from the OUT power 
port. To place net labels on the required nets as shown in Figure 1: 
1. Select Place » Net Label [shortcut P, N], press TAB and enter the net label name. Click to place 

the net label.  

For more information about placing net labels, rrefer to the tutorial Getting Started with PCB 
Design in the Getting Started with Altium Designer book. 

2. Right-click or press ESC to exit net label placement mode. 

3. Select File » Save [shortcut Ctrl+S] to save your circuit. Save the project as well by selecting the 
project name in the Projects panel, right-clicking and selecting Save Project. 

Compiling the project 
Compiling a project checks for drafting and electrical rules errors in the design documents. We will use 
the default rules already set up in the Error Checking and Connection Matrix tabs of the Options for 
Project dialog (Project » Project Options). 

1. To compile our Filter project, select Project » Compile PCB Project. 
2. When the project is compiled, any warnings and errors generated will display in the Messages 

panel. If there are errors, check your circuit and ensure all wiring and connections are correct. 

Setting up the analyses 
Altium Designer allows you to run an array of circuit simulations directly from a schematic. In the 
following sections of the tutorial, we will simulate the output waveforms produced by 
our Filter circuit. 

The simulation can be set up and run using the Simulate menu command or by 
clicking on the appropriate button on the Mixed Sim toolbar (displayed by selecting 
View » Toolbars » Mixed Sim). 
1. With  Filter.SchDoc open in the Schematic Editor, select Design » Simulate » Mix Sim, or click 

on the Setup icon  in the Mixed Sim toolbar, to display the General Setup page of the Analyses 
Setup dialog. The Messages panel may display any warnings or errors about your schematic. Close 
the Analyses Setup dialog, fix any issues and close the Messages panel before selecting the Setup 
tool again. 
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All the simulation options are set up here, including the analyses types you want to include in the 
simulation, the scope of the simulation (sheets to netlist) and the signals to be automatically 
displayed when the simulation is complete (active signals). These options are stored in the project 
file (when saved) and will be used in the creation of a SPICE netlist (*.nsx) which is used when 
the simulation is run. 

2. First, we will set up the nodes in the circuit that we want to observe. In the Collect Data For field, 
select Node Voltage, Supply Current, Device Current and Power from the list. This option 
defines what type of data you want calculated during the simulation run, i.e. it saves data for the 
voltage at each node, the current in each supply and the current and power in each device. Set the 
SimView Setup to Show Active Signals. 

3. In the Available Signals field, double-click on the IN and OUT signal names. As you double-click 
on each one, it will move to the Active Signals field. You can also select multiple signals from the 
Available Signals list by clicking and dragging the mouse over the signal list, or using the SHIFT 
and CTRL keys while clicking on signals. Then use the > button to move the signals to the Active 
Signals list. The simulation results for Active Signals automatically display in the Waveform 
Analysis window when the simulation is run.  
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Press F1 when in 
each analyses setup 
page to view more 
detailed help. 

4. Each individual analysis type (listed in the Analyses/Options section) is 
configured on a separate page of the Analyses Setup dialog. Click on the 
analysis name to activate the corresponding setup page.  

Setting up a Transient/Fourier analysis 
A Transient/Fourier analysis generates output like that normally shown on an oscilloscope, computing 
the transient output variables (voltage, current or power) as a function of time over the user-specified 
time interval.  

An Operating Point analysis is automatically performed prior to a Transient analysis to determine the 
DC bias of the circuit, unless the Use Initial Conditions option is enabled. If this option is enabled, 
the DC bias is calculated from the initial conditions defined in the schematic. The initial condition can 
be defined for each appropriate component in the schematic or .IC devices can be placed in the circuit. 

To view six cycles of the 50KHz excitation voltage, we will set up to view a 60u portion of the 
waveform. 
1. Make sure the Transient/Fourier checkbox is enabled (ticked) in the Analyses Setup dialog for this 

analysis. If the Transient/Fourier Analysis Setup page does not display automatically, click on the 
Transient/Fourier Analysis name in the Analyses/Options list. 

 

2. Check that the Use Transient Defaults option is disabled, so that the Transient Analysis 
parameters can be modified. 

3. To specify a 60u simulation window, set the Transient Stop Time field to 60u. 

4. Now set the Transient Step Time field to 100n, indicating that the simulation should calculate a 
point every 100ns. 

5. During simulation, the actual timestep is varied automatically to achieve convergence and the 
required accuracy. The Maximum Step field limits the variation of the timestep size, so set the 
Transient Max Step Time to 200ns. 
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Setting up an AC Small Signal analysis 
An AC analysis generates output that shows the frequency response of the circuit, calculating the 
small-signal AC output variables as a function of frequency. The desired output of an AC small-signal 
analysis is usually a transfer function, e.g. voltage gain. 

The schematic must contain at least one AC source with a value entered for the AC Magnitude 
parameter in its SIM model. We have already set up the parameters of our sinusoidal excitation source 
(VSIN) to contain the AC Magnitude value, frequency and amplitude. See Setting up voltage sources 
for more information.  
1. Make sure the AC Small Signal Analysis checkbox is enabled in the Analyses Setup dialog. 

 

2. Enter the parameter values as shown above. 

3. When this analysis is run, an Operating Point analysis is run first to determine the DC bias of the 
circuit. The signal source is then replaced with a fixed amplitude sine wave generator and the circuit 
is analyzed over the specified frequency range, stepping in increments defined by the values in the 
Test Points and the Sweep Type fields. 

Running the simulation 
You are now ready to run the enabled analyses.  

Note that you can also run a simulation without entering the Analyses Setup dialog every time by 
clicking on the Run Mixed Signal Simulation button  on the Mixed Sim toolbar. 

1. Click the OK button at the bottom of the Analyses Setup dialog to run the simulation. 

Any warnings or errors produced during the generation of the SPICE netlist, or the actual simulation 
process itself, will be displayed in the Messages panel. Fix any errors before proceeding. 

2. If there are no errors in the circuit, a SPICE netlist (*.nsx) is created and passed to the simulator. 
Note that the netlist will be regenerated each time a simulation is run.  

3. The simulation begins and a simulation data file (*.sdf) will open. The results of each analysis 
are shown as a separate chart in the SimData Editor's Waveform Analysis window. The Operating 
Point analysis is performed first to determine the DC bias of the circuit. 
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4. When the simulation is finished, you should see outputs similar to those shown below. 

 

AC Small Signal analysis waveforms 

 
Operating Point analysis 

 
Transient Analysis waveforms 
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For more information about using the Waveform Analyzer and the Sim Data panel, see Using 
the Waveform Analysis Window in the Performing Signal Integrity Analyses tutorial since both 
tools use the same window for displaying and manipulating waveforms. 

Creating a Bode plot 
A Bode plot consists of two curves — the log of gain and phase — as functions of the log of frequency. 
The gain in decibels (dB) and the phase are plotted linearly along the y axis on a chart that has several 
cycles of a log scale on the x axis. Each cycle represents a factor of ten in frequency. We can create a 
Bode plot using the waveform functions available in the Edit Waveform dialog.  
1. In the AC Analysis tab of the Waveform Analyzer window, we will display dB(in), dB(out), 

PHASE(in) and PHASE(out).  
2. In the Waveform Analyzer window, click on net in. Right-click on the selected net and select 

Edit Wave (or select Wave » Edit Wave). The Edit Waveform dialog displays. The selected 
wave appears in the Expression field. 

 

3. Select the function from the Complex Functions list, i.e. Magnitude (dB). Click on Create to see the 
waveform dB(net_name), i.e. dB(in), on the plot. 

4. To create dB(out), right-click on the plot and select Add Wave to Plot. The Add Wave to Plot dialog 
displays which works in the same way as the Edit Waveform dialog. 

5. Repeat step 4 to create PHASE(in) and PHASE(out) on the second plot by selecting the Phase 
(Deg) complex function in the Add Wave to Plot dialog. 
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6. These waveforms could be displayed on different Y axes, if required, by selecting Add to new Y 
axis in the Edit Waveform dialog. Note that if you remove the new Y axis, all waves that are plotted 
to this axis are removed as well as any measurement cursors attached to these waves. There is no 
Undo functionality. If you added a new Y axis, it would appear as shown below. 

  

Using the measurement cursors 
Now we can determine the 3dB point using the measurement cursors. 
1. Click on the net name DB(out) to select the wave in the Waveform Analyzer window.  

2. Right-click and select Cursor A (or select Wave » Cursor A). Position cursor A in the lowpass 
section by dragging the marker.   

3. Right-click and select Cursor B (or select Wave » Cursor B). Position cursor B at a point such that 
B-A = -3 in the Measurement section of the Sim Data panel.  
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4. Read off the X value of cursor B in the Measurement Cursors section of the Sim Data panel and 
you will find the 3dB point  = 20kHz. 

 

5. To clear the cursors, select the cursor marker, right-click and select Cursor Off. 

Running a Parameter Sweep analysis 
Now that we have set up and run some analyses, let’s set up a parameter sweep to see the effect of 
varying some of the capacitor/resistor values on the frequency response.  

A Parameter Sweep analysis allows you to sweep the value of a device in defined increments, over a 
specified range. AC, DC or Transient analyses must also be enabled in order to perform a Parameter 
Sweep analysis as the simulator performs multiple passes of each enabled analyses. 

This analysis can vary basic component values and model parameters, however subcircuit data is not 
varied during the analysis. 
1. Click on the Filter.SchDoc tab to make the schematic available in the design window. Select 

Design » Simulate » Mixed Sim. Make sure Show Active Signals is selected as the SIMView 
Setup in the General Setup page of the Analyses Setup dialog. 

2. Click on Parameter Sweep in the Analyses/Options section of the Analyses Setup dialog to enable 
this analysis type. 

3. Enter the parameter to be swept in the Primary Sweep Variable field. In this example, we will 
primary sweep parameter C2[capacitance], so select it from the drop-down list.  

4. To define the range of values for the sweep, set the Primary Start Value to 20p and Primary Stop 
Value to -20p. Set the Primary Step Value to define step increments to -10p.  
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5. Set the Primary Sweep Type option to Relative Values. The values entered in the Primary Start 
Value, Primary Stop Value and Primary Step Value fields will be added to the parameter's existing 
or default value.  

6. Click on Enable Secondary to add secondary sweep values. When a Secondary parameter is 
defined, the Primary parameter is swept for each value of the Secondary parameter.  
Set up a secondary sweep for C1[capacitance] with a Secondary Start Value to -80p and 
Secondary Stop Value to 80p. Set the Primary Step Value to define step increments to 80p. Set 
the Secondary Sweep Type to Relative Values. 

 

7. Click OK to run the simulation. Each primary sweep appears as a waveform with the notation 
<net_name_p<sweep_number>, e.g. out_p01, in a new plot in the AC Analysis and Transient 
Analysis tabs of the Waveform Analyzer window.  
Click on a sweep parameter name to display more information, e.g. clicking on out_p01 displays 
the sweep information underneath the plot.  

 
You will notice below that the parameter sweep varies the frequency response around the cutoff 
frequency quite dramatically.  
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Parameter sweep results in the AC Analysis tab 

 
Parameter sweep results in the Transient Analysis tab 

Using Advanced Options 
The Advanced Options page in the Analyses Setup dialog contains a list of internal SPICE options 
that can be set to effect the simulation calculations, such as error tolerances and iteration limits. 

 

To change the value of a SPICE option, e.g. the iteration value for ITL1: 
1. Select the variable, e.g. ITL1. Type in the new value in the Value field, or choose the value by 

clicking on the scroll arrows that appear.  
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To create a netlist 
(.nsx) from a 
schematic, ensure 
that the schematic is 
the active document. 
Select Design » 
Netlist For Project » 
XSpice, or click on 
the Generate XSpice 
Netlist icon  on 
the Mixed Sim 
toolbar. 

2. Press Enter, or click in another field, and the Default (Def) option is then disabled. 

You could also choose a different integration method from this page, for example, if you have a circuit 
design with unexpected high frequency oscillations, you could change the standard Integration method 
from Trapezoidal to Gear. The Trapezoidal method is relatively fast and accurate, but tends to oscillate 
under certain conditions. The Gear methods require longer simulation times but tend to be more stable. 
Theoretically, the higher the Gear order, the more accurate the results but the simulation time 
increases. 

Using a SPICE netlist for simulation 
You can also perform a simulation directly from a SPICE netlist, allowing you to use the Altium 
Designer simulator in conjunction with other schematic capture tools. To do this: 
1. Include the netlist in a project file (.PrjPCB). This allows you to save setup 

information between simulation sessions. Setup information is stored in the 
project file in the same manner as for a project containing schematics. Note 
that a project file is automatically added when you run simulation for the first 
time from P-CAD. If the netlist is opened as a free document, setup information 
will not be stored between sessions of Altium Designer.  

2. The Altium Designer simulation engine requires a netlist that includes the 
component information, design connectivity, the model data, as well as the 
setup information. If there is no simulation setup information already contained 
in the netlist when you select Simulate » Setup, a new netlist is created 
named <original filename>_tmp.nsx. This file contains setup 
information from the project file plus the netlist information from the original .nsx file. 

If there is simulation information present in the netlist, then the simulation is run directly with no 
modifications to the netlist. This is useful for advanced users who want to be able to modify settings 
directly in the netlist. Note that you can not add or configure setup information using the Analyses 
Setup dialog if the netlist already includes any setup information. 

If there is no simulation setup information contained in the netlist but there are schematic 
documents in the project, then the netlist is regenerated from the schematic documents and the 
project's setup information. This would only occur if you deleted the setup information from the 
netlist and then attempted to simulate from it. 

3. Once you have added a netlist which has no setup information to a project, you can configure the 
analyses by selecting Simulate » Setup.  

4. To run a simulation, select Simulate » Run from the menus. The simulation waveforms will display 
in a .sdf document. 

5. Rename the netlist file so it is not overwritten next time you run a simulation. 

For more information about simulation, refer to the Simulation Models and Analyses Reference 
(online only) and the Digital SimCode Reference (online only). 



Defining & running Circuit Simulation analyses 

24 TU0106 (v1.4) January 23, 2005  

Revision History 

Date Version No. Revision 

9-Dec-2003 1.0 New product release 

17-Feb-2005 1.1 Updated for SP2 including Libraries Search queries. 

30-Jun-2005 1.2 Updated for Altium Designer SP4. 

12-Dec-2005 1.3 Path references updated for Altium Designer 6 

23-Jan-2006 1.4 Updated reference to PSpice model support 

Software, hardware, documentation and related materials:  

Copyright © 2005 Altium Limited. 

All rights reserved. You are permitted to print this document provided that (1) the use of such is for personal use 
only and will not be copied or posted on any network computer or broadcast in any media, and (2) no modifications 
of the document is made. Unauthorized duplication, in whole or part, of this document by any means, mechanical or 
electronic, including translation into another language, except for brief excerpts in published reviews, is prohibited 
without the express written permission of Altium Limited. Unauthorized duplication of this work may also be 
prohibited by local statute. Violators may be subject to both criminal and civil penalties, including fines and/or 
imprisonment. Altium, Altium Designer, CAMtastic, Design Explorer, DXP, LiveDesign, NanoBoard, NanoTalk, 
Nexar, nVisage, P-CAD, Protel, CircuitStudio, Situs, TASKING, and Topological Autorouting and their respective 
logos are trademarks or registered trademarks of Altium Limited or its subsidiaries. All other registered or 
unregistered trademarks referenced herein are the property of their respective owners and no trademark rights to 
the same are claimed. 


	Creating a new project 
	Creating a new schematic sheet 
	Drawing the schematic 
	Locating components and loading libraries 

	Placing a simulation-ready component 
	Adding a new SIM model file 

	Setting up simulation-ready resistors 
	Setting up simulation-ready capacitors 
	Adding the voltage sources 
	Adding power ports 
	Wiring up the circuit 
	Nets and net labels 

	Compiling the project 
	Setting up the analyses 
	Setting up a Transient/Fourier analysis 
	Setting up an AC Small Signal analysis 

	Running the simulation 
	Creating a Bode plot 
	Using the measurement cursors 

	Running a Parameter Sweep analysis 
	Using Advanced Options 
	Using a SPICE netlist for simulation 
	Revision History 

