Unterschiede

Hier werden die Unterschiede zwischen zwei Versionen angezeigt.

Link zu dieser Vergleichsansicht

Beide Seiten der vorigen RevisionVorhergehende Überarbeitung
Nächste Überarbeitung
Vorhergehende Überarbeitung
software:eclipse:eclipse_serial_terminal [2013-09-10 12:00] grafsoftware:eclipse:eclipse_serial_terminal [Unknown date] (aktuell) – gelöscht - Externe Bearbeitung (Unknown date) 127.0.0.1
Zeile 1: Zeile 1:
-====== Eclipse Serial Terminal ====== 
-Es gibt eine Möglichkeit in Eclipse ein Terminal einzublenden.  
-Dieses Terminal erlaubt die Kommunikation über serielle Schnittstellen,  
-SSH und Telnet ähnlich wie Putty. 
-===== Installation ===== 
-Um das Terminal verwenden zu können, muss zuerst die RXTX Library  
-installiert werden. Unter [[http://rxtx.qbang.org/wiki/index.php/Installation|RXTX]] gibt es eine  
-Installationsanleitung. Auf den NTB-Rechnern ist die Bibliothek bereits installiert. 
  
-Danach müssen in Eclipse zwei Plug-Ins installiert werden.  
-Dazu in Eclipse auf //Help -> Install new Softwares// klicken. Dann unter  
-//Work with// das Pulldown Menu öffnen und die aktuelle Eclipse Versions  
-Updateseite wählen z.B Helios http://download.eclipse.org/releases/helios.  
-Unten im Fenster werden mögliche Plug-Ins angezeigt. Dort wählt man  
-unter //Mobile and Device// //Development Target Management Terminal// aus.  
-Danach klickt man auf //Finish// und folgt dem Installations-Wizzard. 
- 
-Für das zweite Plugin wieder unter //Help -> Install new Softwares// auf //Add..//  
-klicken unter Name: //RXTX// und unter  
-Location: // http://rxtx.qbang.org/eclipse/ // eingeben.  
-Nach einem Klick auf OK werden wieder mögliche Plug-Ins angezeigt.  
-Dort die neuste Version von RXTX wählen und die Schritte  
-von oben wiederholen.\\ 
-Auf der eclipse-Installation der NTB sind die zwei Plugins bereits enthalten. 
- 
-===== Terminal anzeigen und benutzen ===== 
-Das Terminal kann man in Eclipse unter  
-//Window -> Show View -> Other.. ->Terminal// öffnen.  
-Die Bedienelemente zur Konfiguration, Verbindungsaufbau etc.  
-befinden sich auf der rechten Seite.  
-{{  :software:eclipse:terminal.png?400  }} 
- 
- 
-===== MPC 555 und  USB Virtual Com Port ===== 
-Wird mit dem virtuellem Com Port des MPC555 (SCI1) eine Verbindung aufgebaut und anschliessend der Prozessor ausgeschaltet, wird die Verbindung nicht automatisch getrennt. Versucht man nun eine Nachricht zu senden, stürzt Eclipse ab. 
-Deshalb muss die Verbindung unbedingt getrennt werden, bevor der Prozessor wieder gestartet wird. 
- 
-Da die Clockfrequenz des MPC555 und des Prozessors, der sich auf dem USB-BDI Board befindet, unterschiedlich sind, kommt es bei höheren Bitraten zu Problemen. Wenn im Terminal eine Baudrate von 57600 gewählt wird, muss auf dem MPC555 im seriellen Treiber für die SCI1 eine Baudrate von 55000 eingestellt werden. Das passiert in der Methode //start()// Bei der Baudrate von 115200 muss analog dazu 108000 eingestellt werden. Das Gesagte gilt aber nur für den virtuellen COM-Port (SCI1 über USB). Die SCI2 kann beliebig konfiguriert werden.